|
List of References [1] Albert D. Alexandrov, Maximilian Ibel, Klaus E. Schauser, and Chris J. Scheiman, Extending the Operating System at the User Level:the Ufo Global File System, Proceedings of the USENIX Annual Technical Conference, January, 1997. [2] B. Allcock, J. Bester, J. Bresnahan, A. L. Chervenak, I. Foster, C. Kesselman, S. Meder, V. Nefedova, D. Quesnal, S. Tuecke, Data Management and Transfer in High Performance Computational Grid Environments. Parallel Computing Journal, Vol. 28 (5), May 2002, pp. 749-771. [3] Rasmus Andersen, and Brian Vinter, Transparent Remote File Access in the Minimum Intrusion Grid, http://mig-1.imada.sdu.dk. [4] Birrel, A. and B. Nelson, Implementing remote procedure calls, ACM Transactions on Computer Systems 2(1), Feb 1984, pp.39-59. [5] Bray, T. Bonnie Source Code. Netnews Posting, 1990. [6] F. E. Bustamante, G. Eisenhauer, K. Schwan, and P. Widener, Efficient wire formats for high performance computing. In Proceedings of the 2000 Conference on Supercomputing, 2000. [7] A. Chervenak, I. Foster, C. Kesselman, C. Salisbury, and S. Tuecke, The Data Grid: Towards an Architecture for the Distributed Management and Analysis of Large Scientific Datasets, Journal of Network and Computer Applications, 23:187-200, 2001.(Based on conference publication from Proceeding of NetStore Conference 1999). [8] Chiu, K., Govindaraj, M., and Bramley, R. Investigating the Limits of SOAP Performance for Scientific Computing. In Proceedings of 11th. IEEE International Symposium on High Performance Distributed Computing HPDC-11 2002 (HPDC’02). [9] Curbera, F., Duftler, M. & Khalaf, R. 2002. Unraveling the Web servicess Web – An Introduction to SOAP, WSDL and UDDI”, IEEE Internet Computing 86-93. [10] Davis, D. and Parashar, M. Latency Performance of SOAP Implementations, In 2nd IEEE/ACM International Symposium on Cluster Computing and the Grid (CCGRID'02). [11] M. L. Dertouzos. The future of computing, Scientific American, pages 52-55, 1999. [12] Robert van Engelen, Gunjan Gupta, and Saurabh Pant, Developing Web servicess for C and C++, in IEEE Internet Computing Journal, March, 2003, pages 53-61. [13] Robert van Engelen. gSOAP 2.7.1 User Guide http://www.cs.fsu.edu/~engelen/soapdoc2.html [14] R. van Engelen, Code Generation Techniques for Developing LightWeight XML Web servicess for Embedded Devices, proceedings of the ACM SIGAPP SAC Conference, 2004 (Embedded Systems track). [15] Foster I., Kesselman C., Nick J. and Tuecke S. (2002) the physiology of the Grid: An Open Grid Services Architecture for Distributed Systems Integration. http://www.globus.org/research/papers/ogsa.pdf [16] FUSE (Filesystem in Userspace ) http://fuse.sourceforge.net/ [17] The Globus Alliance http://www.globus.org [18] Grid computing http://www-ad.fsl.noaa.gov/ac/GridComputing.html [19] GridFTP http://www.globus.org/datagrid/gridftp.html [20] THE GLOBUS PROJECT White Paper GridFTP Universal Data Transfer for the Grid http://www-fp.globus.org/datagrid/deliverables/C2WPdraft3.pdf [21] GFS http://www.sistina.com/products_gfs.htm [22] Brice Goglin and ENS Lyon , Performance Analysis of Remote File System Access over a High-Speed Local Network , Proceedings of the 18th International Parallel and Distributed Processing Symposium (IPDPS’04), 2004 IEEE. [23] gSOAP http://gsoap2.sourceforge.net/ [24] J. H. Howard. An Overview of the Andrew File System. In Proceeding of the USENIX Winter Technical Conference, page 23-26, 1998. [25] IBM Accelerates Grid Computing Across the Automotive and Transportation Industries. ARMONK, NY, March 24, 2005. http://www-1.ibm.com/grid/grid_press/pr_032405.shtml. [26] IDC’s Worldwide Handheld QView, Feb 2005. [27] Intermezzo, http://www.inter-mezzo.org/ [28] M. L. Kazar, B. W. Leverett, O.T. Anderson, V. Apostolides, B. A. Bottos, S. Chutani, C. F. Everhart, W. A. Mason, S.-T. Tu, and E. R. Zayas, Decorum File System Architectural Overview. In Proceedings of the summer 1990 USENIX Technical Conference, June 1990. [29] L. Kleinrock, ”Nomadic Computing –An Opportunity,” Computer comm. Rev., vol. 25,no. 1,Jan,1995. [30] C. Kohloff and R. Steele, “Evaluating SOAP for High Performance Business Application: Real-Time Trading Systems”, accepted to WWW2003, Budapest, Hungary, 2003. [31] Jonghyun Lee, Ross, R. Thakur, R. Xiaosong Ma, Winslett, M. RFS: efficient and flexible remote file access for MPI-IO. Cluster Computing, 2004 IEEE International Conference, page: 71- 81, Sept. 2004. [32] Chuck Lever, Peter Honeyman Linux NFS Client Write Performance, In Proceedings of the Usenix Technical Conference, FREENIX track, Monterey, June 2001. http://www.textuality.com/bonnie/intro.html [33] Ravi K Madduri, Cynthia S. Hood, William E. Allcock, RELIABLE FILE TRANSFER IN GRID ENVIRONMENTS, Proceedings of the 27th Annual IEEE Conference on Local Computer Networks(LCN.02), 2002 IEEE. [34] John Merrells, Web servicess Security & Access Control,XML 2004 Proceedings by SchemaSoft. [35] Nikolaos Michalakis (New York U.), and Dimitris N. Kalofonos (Nokia), Designing an NFS-based Mobile Distributed File System for Ephemeral Sharing in Proximity Networks, 4th Workshop on Applications and Services in Wireless Networks, August 8-11, 2004. [36] L. B. Mummert, M. R. Ebling, and M. Satyanarayanan, Exploiting Weak Connectivity for Mobile File Access. In Proceedings of the 15th ACM Symposium on Operating Systems Principles, Copper Mountain Resort, Colorado, USA, December 1995. [37] L. B. Mummert. Exploiting Weak Connectivity in a Distributed File System. PhD thesis, Carnegie Mellon University, School of Computer Science, 1996. [38] NFSv4 http://www.nfsv4.org [39] Learning NFSv4 with Fedora Core 2 (Linux 2.6.5 Kernel) http://www.vanemery.com/Linux/NFSv4/NFSv4-no-rpcsec.htm [40] B. Noble, B. D. “Mobile Data Access, ”PhD thesis, Carnegie Mellon University, May 1998. [41] Common Object Request Broker Architecture, OMG, July, 1995, http://www.omg.org [42] Open GFS http://www.opengfs.org/ [43] Open Grid Services Architecture Homepage. http://www.globus.org/ogsa [44] Open Grid Services Infrastructure Working Group, https://forge.gridforum.org/projects/ogsi-wg [45] B. Pawlowski, C. Juszczak, P. Staubach, C. Smith, D. Lebel, and D. Hitz, NFS Version 3 Design and Implementation. In Proceedings of the Summer 1994 USENIX Technical Conference, Jun 1994. [46] Brian Pawlowski, Spencer Shepler, Carl Beame, Brent Callaghan, Michael Eisler,David Noveck, David Robinson, Robert Thurlow, The NFS Version 4 Protocol, 2nd International SANE Conference, May 2000. [47] Roblimo, “Linux needs better network file systems”, http://servers.linux.com/article.pl?sid=04/11/29/1535215 [48] RFC 959: File Transfer Protocol, http://www.w3.org/Protocols/rfc959/ [49] RFC1521: Base64, http://www.ietf.org/rfc/rfc1521.txt?number=1521. [50] RFC2617: HTTP Authentication: Basic and Digest Access Authentication, http://www.ietf.org/rfc/rfc2617.txt [51] Debashis Saha and Amitava Mukherjee, "Pervasive computing: a paradigm for the 21st century", IEEE Computer, 36(3):25-31, March 2003. [52] R. Sandberg, D. Goldberg, S. Kleiman, D. Walsh, and B. Lyon, Design and Implementation of the Sun Network File System. In USENIX Summer Conference Proceedings. USENIX Association, June 1985. [53] M. Satyanarayanan. Scalable, Secure, and Highly Available Distributed File Access. Computer, 23(5), May 1990. [54] M.Satyanarayanan, “Fundamental Challenges in Mobile Computing, ”Proc. Fifteenth ACM symp. Principles of Distributed Computing, May 1996. [55] GFS: http://www.sistina.com/products_gfs.htm [56] Silberschatz, Galvin, and Gagne, Operating system concepts sixth edition, wiley. [57] Aaron Skonnard. SOAP: The Simple Object Access Protocol, Microsoft Corporation, http://www.microsoft.com/mind/0100/soap/soap.asp [58] Aaron Skonnard. Understanding SOAP, Microsoft Corporation, http://msdn.microsoft.com/library/default.asp?url=/library/enus/dnsoap/html/understandsoap.asp [59] W3C Working Draft 9 July 2001, SOAP Version 1.2, http://www.w3.org/TR/2001/WD-soap12-20010709/#_Toc478383512 [60] W. Richard. Stevens, Advanced Programming in the UNIX Environment. [61] Min Tian, Thiemo Voigt, Tomasz Naumowicz, Hartmut Ritter and Jochen Schiller. Performance Considerations for Mobile Web servicess. Elsevier Computer Communications Journal, Volume 27, Issue 11, 1 July 2004, Pages 1097-1105. [62] Universal Plug and Play "Understanding Universal Plug and Play: a White Paper", June 2000, http://upnp.org/resources/whitepapers.asp [63] XML within IETF Protocols, http://xml.coverpages.org/draft-hollenbeck-ietf-xml-guidelines-04.txt
|