跳到主要內容

臺灣博碩士論文加值系統

(216.73.216.249) 您好!臺灣時間:2026/10/09 01:42
字體大小: 字級放大   字級縮小   預設字形  
回查詢結果 :::

詳目顯示

: 
twitterline
研究生:陳明志
研究生(外文):Ming-Chi Chen
論文名稱:預算法全IP核心網路服務品質管理之分散式資源管理
論文名稱(外文):Distributed Resource Management and Admission Control in Budget-Based QoS Management for All-IP Core Networks
指導教授:連耀南連耀南引用關係
指導教授(外文):Yao-Nan Lien
學位類別:碩士
校院名稱:國立政治大學
系所名稱:資訊科學學系
學門:工程學門
學類:電資工程學類
論文種類:學術論文
論文出版年:2003
畢業學年度:92
語文別:中文
論文頁數:99
中文關鍵詞:BBQ、QoS、DiffServ、All-IP
相關次數:
  • 被引用被引用:1
  • 點閱點閱:229
  • 評分評分:
  • 下載下載:24
  • 收藏至我的研究室書目清單書目收藏:1
通訊與資訊科技的大幅進步,電信自由化帶來的激烈競爭,以及網際網路的蓬勃發展,刺激大量多媒體網路資訊的流通,為了因應此種趨勢,網路提供者已趨向合併數據及電信網路朝單一的All-IP網路方向發展。為了保證時效性服務在All-IP網路上的品質,網路服務品質(QoS)已成為All-IP網路的主要研究議題。不同的網路應用各有不同的特性與需求;對於那些比較不注重傳輸延遲時間的應用,增加網路頻寬或許就已足夠應付需求,但是對於那些具有互動特性 (interactive)、重視傳輸延遲時間的應用,像VoIP,除了增加網路頻寬外,All-IP網路必須提供服務品質保證才能獲得網路營運者的支持。本研究團隊設計一個管理架構,在此架構上提供完整的End-to-End QoS保證,以符合All-IP網路上各種不同服務需求。本文中另外提出以預先批購頻寬的方式進行核心網路資源規劃,根據需求預測,考量批購成本期望值,決定出適當之頻寬預購值。於執行時段提出數個允入控制資源不足解決方案,並且配合執行時段頻寬管理機制,掌握頻寬使用情形,以達到順利允入網路訊務之目的。最後於NS2平台以實驗模擬的方式,評估本文中所提出之預先批購頻寬與執行時段頻寬管理機制,從結果中我們發現本研究所提出之頻寬預購方法可以有效預防因為預測誤差所造成之資源不足現象,配合執行時段頻寬管理機制可根據執行時期之資源使用狀況,在資源缺乏時提前進行頻寬補充,以順利允入訊務,提升使用率。
Because of great progress of communication and computer technology, aggressive deployment of broadband fiber optical network, advance of Internet technology, and the global standardization of IP technology, the telecommunication industry is moving toward a converged network, which uses a single global IP based packet-switching network to carry all types of network traffics. In these types of network traffics, different traffic types require corresponding service to ensure end- to-end quality. For carrying all types of network traffics on All-IP network, BBQ (Budget-Based QoS) research group propose a QoS system architecture to provide end-to-end QoS guarantee. In this thesis, basing on BBQ QoS system, we propose resource pre-planning mechanism to management core network. According to demand forecast from historical data and considering pre-planning cost, pre-planning mechanism will find optimal policy to reduce management cost. Besides resource pre- planning, we also propose several solutions to avoid resource shortage at run-time. Through intensive evaluation in network simulatior-2(ns2), we demonstrate that our resource pre-planning can minimize resource cost and cover some forecasting error. And run-time resource management can maintain reasonable in-hand resource at run-time to reduce the effect of resource shortage.
目錄
第一章 簡介 1
1.1 電信產業的趨勢 2
1.1.1 整合型網路(Network Convergence-All-IP Network) 3
1.1.2 封包網路上乘載具時效性應用問題 (Real-time Application on Packet-Switching Networks) 4
1.2 服務品質保證定義(QoS Definitions) 6
1.2.1 分歧的品質保證期望(Diversified QoS Expectations) 6
1.3 全IP網路之服務品質保證(QoS over All-IP Network) 7
1.4 UMTS服務等級(UMTS QoS Service Class) 7
1.5 QoS管理方法(QoS Management) 9
1.5.1 Intergrated Service 9
1.5.2 Differentiated Service 9
1.6 研究動機與目的(Motivation and Research Objective) 10
1.7 解決方案(Solution Approaches) 11
1.8 論文組織架構 12
第二章 相關研究(Related Work) 14
2.1. QoS 管理架構 14
2.1.1 Integrated Service 14
2.1.2 Differentiated Service 15
2.1.3 TEQUILA 19
2.1.4 Victor O.K. Li''s System 21
2.2 評論(Summary) 22
第三章 以預算為基礎之服務品質保證(Budget-Based QoS) 24
3.1 BBQ架構(Budget-Based QoS Framework) 25
3.1.1 簡化的All-IP網路架構(A Simplified All-IP Network Architecture) 25
3.1.2 以預算為基礎之管理(Budget-Based Management) 26
3.1.3 路徑定義(Paths Definitions) 27
3.1.4 承載服務架構(Bearer Service Architecture) 28
3.1.5 服務品質熵數(Quality Entropy) 29
3.1.6 即時資源分配與預先資源管理(Pre-Planning vs. On Demand Allocation) 31
3.1.7 集中式配置與分散式配置(Centralized Allocation vs. Distributed Allocation) 32
3.1.8 需求預測 33
3.2 管理系統架構(Management System Architecture for BBQ) 34
3.2.1 BBQ管理系統假設(BBQ System Assumptions) 34
3.2.2 分散式分層管理系統(Distributed Management System Hierarchy) 35
3.2.3 管理系統軟體架構(Management System Software Architecture) 36
3.2.4 簡化的端對端服務品質建立流程(A Simplified End-to-End Path Setup Procedure) 37
3.3 BBQ中的核心網路架構與QoS元件(Core Network Architecture and QoS Components for BBQ) 38
3.3.1 核心網路資源規劃方法 39
3.3.2 核心網路內的資源規劃元件 40
3.3.3 分散式資源規劃運作流程 42
第四章 資源管理與允入控制 45
4.1 預購法頻寬規劃 45
4.1.1 Historical Traffic Pattern 45
4.1.2 最佳預購頻寬 47
4.1.2.1.最佳化模型(Optimization Model) 49
4.1.2.2.索取費率與預購頻寬 53
4.1.2.3.多重服務等級之預購方案 53
4.1.3 預購資源不足之解決方案 54
4.2 執行時段(Current Execution Time Period)之允入控制與資源管理 56
4.2.1 允入控制流程 56
4.2.2 執行時段資源管理 57
4.2.3 執行時段資源不足之解決方案 58
4.2.3.1.資源再分配 58
4.2.3.2.訊務降級 59
4.2.3.3.臨時批購 59
4.2.4 執行時段頻寬管理最佳化模型 60
第五章 效能評析 64
5.1 評估指標 64
5.1.1 效能評估指標 65
5.1.1.1.完全滿足比例(Ratio of Full-Satisfied Traffic Request) 65
5.1.1.2. 部分滿足比例(Ratio of Partially-Satisfied Traffic Request) 65
5.1.1.3.拒絕比例(Ratio of Rejected Traffic Request) 65
5.1.2 管理成本(management cost)與獲利(profit) 65
5.2 模擬環境 66
5.2.1 NS2模擬平台 66
5.2.2 訊務類型(Traffic Source Type) 66
5.2.3 拓樸設計(Topology Design) 67
5.3 實驗設計 67
5.3.1 訊務產生函式( Traffic Generating Function) 67
5.3.2 頻寬預購法 67
5.3.2.1.頻寬預購法實驗設計 67
5.3.2.2.頻寬預購法模擬過程 67
5.3.3 執行時段(Current Execution Time Period)資源管理 68
5.3.3.1.執行時段資源管理實驗設計 68
5.3.3.2.執行時段資源管理模擬過程 69
5.4 實驗結果 72
5.4.1 預購頻寬規劃實驗結果 72
5.4.1.1.訊務分佈對於獲利之影響 72
5.4.1.2.收費比例對於獲利之影響 74
5.4.1.3.訊務型態對於獲利之影響 77
5.4.2 執行時段(Current Execution Time Period)資源管理實驗結果 79
5.4.2.1.訊務分佈對於效能評估指標之影響 79
5.4.2.2.訊務型態對於效能評估指標之影響 82
5.5 總結 86
第六章 結論 87
6.1 結論 87
6.2 結論與未來發展方向 88
Acknowledgement 89
Reference 89
圖目錄
圖1. 1 : 各UMTS服務類別對三大品質指標之容忍度 8
圖2. 1 : DIFFSERV DOMAIN & NON-DIFFSERV DOMAIN 16
圖2. 2 : TEQUILA架構 20
圖2. 3:分散式管理架構 21
圖3. 1 : 簡化的全IP網路架構 26
圖3. 2 : 端對端承載服務 29
圖3. 3 : 服務品質熵數與品質參數對應 30
圖3. 4 : BBQ管理系統軟體元件架構 36
圖3. 5 : 簡化的端對端服務品質建立流程 37
圖3. 6 : BBQ架構之核心網路 39
圖3. 7 : 核心網路管理架構 42
圖3. 8 : 核心網路資源分配流程 43
圖4. 1 :以時段作為區分的流量統計 X:時段;Y:該時段之BANDWIDTH;Z:DAY 46
圖4. 2:BANDWIDTH DEMAND AT RTPS WITH RESPECT TO A CTP 46
圖4. 3:DEMAND DISTRIBUTION AT RTPS WITH RESPECT TO A CTP 47
圖4. 4:根據歷史資料決定Θ,用來當作預先批購的頻寬 48
圖4. 5 : 左圖 : 批購的頻寬大於該時段的頻寬需求 48
圖4. 6:最佳BANDWIDTH REQUEST VALUEΘ 49
圖4. 7:EXPECTED COST、PRE-ORDER COST AND ON-DEMAND COST 50
圖4. 8:EXPECTED COST、PRE-ORDER COST、ON-DEMAND COST AND OPTIMAL Θ 51
圖4. 9:頻寬預購流程 55
圖4. 10:允入控制流程 56
圖4. 11: 處理不規律之訊務需求所剩資源 58
圖4. 12: 執行時段頻寬管理流程 60
圖5. 1:實驗流程 69
圖5. 2:訊務依照進入時間點的統計情形 71
圖5. 3:透過NS2圖形介面觀察不同時間點的網路情況 71
圖5. 4:四種CBR TRAFFIC分佈對於MEAN、Θ與TOTAL ON-DEMAND之結果 73
圖5. 5:四種CBR TRAFFIC分佈對於MEAN、Θ與TOTAL ON-DEMAND之PROFIT 74
圖5. 6: 費用比例(C2/C1)與最佳頻寬預購值 75
圖5. 7:四種CBR TRAFFIC分佈對於不同費用比例之結果 76
圖5. 8:四種CBR TRAFFIC分佈對於不同費用比例之PROFIT 77
圖5. 9:四種EXPONENTIAL分佈對於MEAN、Θ與TOTAL ON-DEMAND之結果 78
圖5. 10:四種EXPONENTIAL分佈對於MEAN、Θ與TOTAL ON-DEMAND之PROFIT 78
圖5. 11:CBR不具執行時段頻寬管理之完全滿足比例 80
圖5. 12:CBR具執行時段頻寬管理之完全滿足比例 80
圖5. 13:CBR不具執行時段頻寬管理之部分滿足比例 81
圖5. 14:CBR具執行時段頻寬管理之部分滿足比例 81
圖5. 15:CBR不具執行時段頻寬管理之拒絕比例 82
圖5. 16:CBR具執行時段頻寬管理之拒絕比例 82
圖5. 17:EXPONENTIAL不具頻寬管理之完全滿足比例 83
圖5. 18:EXPONENTIAL具頻寬管理之完全滿足比例 83
圖5. 19:不具頻寬管理之部分滿足比例 84
圖5. 20:具頻寬管理之部分滿足比例 84
圖5. 21:EXPONENTIAL不具頻寬管理之拒絕比例 85
圖5. 22:EXPONENTIAL具頻寬管理之拒絕比例 85
表目錄
表1. 1 : 各種新興的網路技術 3
表1. 2 : 傳統電信網路,網路網路和整合型網路特性比較表 3
表1. 3 : CIRCUIT-SWITCHING 與PACKET-SWITCHING NETWORK 特性比較 5
表1. 4 : 3GPP UMTS 品質分及與各項特性 8
表1. 5 : UMTS QOS與 DIFFSERV QOS間之服務對應 9
表2. 1:各種PHB的服務範例 18
表3. 1 : 分層之路徑定義 28
表3. 2 : BBQ管理系統層級分工 35
表5. 1:TRAFFIC DISTRIBUTION SET OF OFF-LINE PLANNING 68
表5. 2:DISTRIBUTION SET OF CURRENT EXECUTION TIME PERIOD MANAGEMENT 70
Reference
[1] Xiao, X., L. -M. Ni, "Internet QoS: A Big Picture", IEEE Network, 13(2):8-18, March-April 1999.
[2] Miras, D., "Network QoS Needs of Advanced Internet Applications", Internet2 - QoS Working Group, November 2002.
[3] Pascal Lorenz, "Quality of service and new architectures for future telecommunications networks", MILCOM 2000 - IEEE Military Communications Conference, no. 1, October 2000 pp. 695-698.
[4] D. Goderis, S. Van den Bosch, Y. T''Joens, P. Georgatsos, D. Griffin, G. Pavlou, P. Trimintzios, G. Memenios, E. Mykoniati, C. Jacquenet, "A service-centric IP quality of service architecture for next generation networks", NOMS 2002 - IEEE/IFIP Network Operations and Management Symposium, no. 1, April 2002 pp. 139-154
[5] Mahbubul Alam, Ramjee Prasad, John R. Farserotu, "Quality of service among IP-based heterogeneous networks", IEEE Personal Communications, no. 6, December 2001 pp. 18-24
[6] Vijay K. Garg, Oliver T. W. Yu, "Integrated QoS support in 3G UMTS networks", WCNC 2000 - IEEE Wireless Communications and Networking Conference, no. 1, September 2000 pp. 1187-1192
[7] E. Crawley, Editor, L. Berger, S. Berson, "A Framework for Integrated Services and RSVP over ATM", RFC 2382, August 1998.
[8] D. Black, M. Carlson, E. Davies, Z. Wang, "An Architecture for Differentiated Services", RFC 2475, December 1998.
[9] Jacobson, V., K. Nichols, K. Poduri, "An Expedited Forwarding PHB", RFC 2598, June 1999.C. Hedrick, ''Routing Information Protocol'''', RFC 1058, June 1988.
[10] Heinanen, J., F. Baker, W. Weiss, and J. Wroclawski, "Assured Forwarding PHB Group", RFC 2597, June 1999.
[11] P. Trimintzios et al., "A Management and Control Architecture for Providing IP Differentiated Services in MPLS-Based Networks", IEEE Commun. Mag., vol. 39, no. 5, May 2001, pp. 80-88.
[12] P. Trimintzios et al., "A Policy-Based Quality of Service Management System for IP DiffServ Networks," IEEE Network., vol. 16, no. 2, Mar 2002, pp. 50-56.
[13] Eleni Mykoniati et al., "Admission Control for Providing QoS in DiffServ IP Networks: The TEQUILA Approach," IEEE Commun. Mag. Jan 2003, pp. 38-44.
[14] Spiridon Bakiras and Victor O.K. Li, "Efficient Resource Management for End-to-End QoS Guarantees in DiffServ Networks", IEEE International Conference on Communications, 2002.
[15] Clark, D., W. Fang, Explicit Allocation of Best Effort packet Delivery Service, IEEE/ACM Transactions on Networking, 6(4):364-373, August 1998.
[16] Douglas S.Reeves and Hussein F. Salama, ''A Distributed Algorithm for Delay-Constrained Unicast Routing'''', IEEE Transaction on Network, April 2000.
[17] R. Braden, L. Zhang, S. Berson, S. Herzog and S. Jamin, ''Resource Reservation Protocol (RSVP) — Version 1 Functional Specification'''', RFC 2205, September 1997.
[18] K. Chan, R. Sahita, S. Hahn and K. McCloghrie, ''Differentiated Services Quality of Service Policy Information Base '''', RFC 3317, March 2003.
[19] Bill Goodman, ''Internet Telephony and Modem Delay'''', IEEE Network, May 1999, pp. 8-16.
[20] J. Garcia-Luna-Aceves and J. Behrens, ''Distributed scalable routing based on vectors of link states'''', IEEE J. Select on Communication, October 1995.
[21] Jon Postel, ''Internet Protocol'''', RFC 791, September 1981.
[22] Mark A. Sportack, ''IP Routing Fundamentals'''', Cisco ISBN: I-57870-071-x, May 1999.
[23] R. Wideyono, ''The Design and Evaluation of Routing Algorithms for Real-Time Channels'''', International Computer Science Institute, Univ. of California at Berkeley, Tech Rep. ISCI TR-94-024, June 1994.
[24] S. Rampal and D. Reeves, ''An evaluation of routing and admission control algorithms for multimedia traffic'''', Proc. of the 5th IFIP Conf. on High Performance Networks, October 1995.
[25] S. Lavenberg, ''Mean Value Analysis of Closed Multichain Queuing Networks'''', Journal of the Association for Computing Machinery, vol. 27, no. 2, April 1980, pp. 313-322.
[26] Z. Wang and J. Crowcroft, ''Quality of Service Routing for Supporting Multimedia Applications'''', IEEE Select on Communication, September 1996.
[27] Walter Weiss, ''QoS with Differentiated Services'''', Bell Labs Technical Journal, October — December 1998.
[28] Nicolas Christin and Jörg Liebeherr, '' A QoS Architecture for Quantitative Service Differentiation '''', IEEE Communications Magazine, June 2003
[29] Fall, K., K. Varadhan, The ns Manual, http://www.isi.edu/nsnam/ns/, April 2002.
[30] 吳柏林與陸行, 國立政治大學應數系, ''航空機位超額預售與收益經營策略''''。
QRCODE
 
 
 
 
 
                                                                                                                                                                                                                                                                                                                                                                                                               
第一頁 上一頁 下一頁 最後一頁 top
1. 詹志禹(民89)。評量為什麼要進行─回應吳毓瑩「評量的蛻變與突破」。教育資料與研究,13,45-47。
2. 謝祥宏、段曉林(民90)。教學與評量─一種互為鏡像(mirror image)的關係。科學教育月刊,241,1-12。
3. 張麗麗(民91)。評量改革的應許之地,虛幻或真實?─談實作評量之作業表現與表現規準。教育研究月刊,93,76-86。
4. 蔡清田(民91)。透過行動研究,實施九年一貫課程,進行學生本位課程發展。教育研究月刊,93,51-67。
5. 鄭富森(民89)。多元化評量的十大難題。測驗與輔導,159。
6. 盧劍峰(民91)。生活科技課程如何落實多元評量。生活科技教育,35(11)。
7. 蔡錫濤(民90)。九年一貫生活科技課程的實踐。生活科技教育,34(10)。
8. 陳新轉(民91)。社會學習領域能力指標之「能力表徵」課程轉化模式。教育研究月刊,100,86-90。
9. 秦麗花(民90)。教師如何進行行動研究。翰林文教雜誌網路版,
10. 陳嘉成、林素微(民89)。因應九年一貫課程自然與生活科技領域的教學評量之我見,測驗與輔導,159。
11. 葉連祺(民90)。中小學教師行動研究策略之探討。教育資料與研究雙月刊,35。
12. 蔡錫濤(民91)。九年一貫自然與生活科技課程實施的困境與對策。生活科技教育,35(10)。
13. 鄒慧英(民89)。多元化的檔案評量。國教之友,52(1),16-23。
14. 陳玫良(民91)。評量規準(Rubric)在生活科技教學評量上的運用。生活科技教育,35(1)。
15. 葉連祺(民91)。九年一貫課程與基本能力轉化。教育研究月刊,96,49-63。