跳到主要內容

臺灣博碩士論文加值系統

(216.73.216.31) 您好!臺灣時間:2026/10/17 13:59
字體大小: 字級放大   字級縮小   預設字形  
回查詢結果 :::

詳目顯示

我願授權國圖
: 
twitterline
研究生:劉岳鑫
研究生(外文):Liu Yueh Hsin
論文名稱:以IOTP建構符合行動通訊實務的B2C電子商務安全研究
論文名稱(外文):A Secure B2C Mobile Commerce Protocol Integrated into the Internet Open Trading Protocol
指導教授:詹進科詹進科引用關係、陳育毅
學位類別:碩士
校院名稱:國立中興大學
系所名稱:資訊科學研究所
學門:工程學門
學類:電資工程學類
論文種類:學術論文
論文出版年:2005
畢業學年度:93
語文別:中文
論文頁數:95
中文關鍵詞:IOTP、行動商務、電子交易、電子商務
外文關鍵詞:IOTP、E-commerce、mobile commerce、E-business
相關次數:
  • 被引用被引用:0
  • 點閱點閱:434
  • 評分評分:
  • 下載下載:0
  • 收藏至我的研究室書目清單書目收藏:2
近年來由於資訊技術與網路科技的爆炸性發展,網路交易已成為大眾喜愛的一種交易方式,因此造就了電子商務的興起。電子商務充分利用了資訊網路技術,讓使用者能有更方便的交易模式並擁有更多的交易機會,電子商務簡化了交易的中間環節,縮短交易時間,節省交易費用,提高了經濟效率和效益。
  電子商務成長的速度十分快速,因此在目前的環境下有許多不同的系統架構,但是卻無法有效整合出一套標準程序,使得電子商務的環境日趨複雜。於是IETF組織便針對電子商務制定了一套IOTP互動式架構,在此架構的規範下,網路交易將可以有一個統一的標準流程與資料交換格式。
  然而由於行動設備如手機、PDA等的盛行,人們可以透過這些行動設備來進行網路交易,不會受到時間與地點的限制,行動商務時代開始了。不像電子商務發展已有一段時間,行動商務還沒有一套有效且成功的架構,而行動商務與電子商務的交易模式有其相同之處,因此在本文章中,我們試著將IOTP與一個設計完整的行動商務架構結合,透過行動商務架構彌補IOTP在行動交易模式方面的不足,並利用IOTP本身使用XML格式,擁有容易跨平台的特性,以期將IOTP應用於行動商務上。
The Internet Open Trading Protocol (IOTP) provides an interoperable framework for Internet commerce. It is payment system independent and encapsulates payment systems such as SET, Mondex, CyberCash, DigiCash, GeldKarte, etc. It identifies five major trading roles. IOTP is able to handle cases where such merchant roles as the shopping site, the Payment Handler, the Delivery Handler of goods or services, and the provider of customer support are performed by different parties or by one party. This specification of version 1.0 is Baseline IOTP. It is a Baseline in that it contains ways of doing trades on the Internet which are the most common.
However,mobile commerce becomes an important role in E-business because of the convenience of mobile device.But the scenarios IOTP version 1.0 concerned about is taking place in the way consumers and merchants trade(B2C).In this paper,we try to integrate a secure mobile commerce protocol into IOTP.
第一章 緒論

1.1 研究背景------------------------------------------------------------------------------------------5
1.1.1 電子商務-----------------------------------------------------------------------------------------5
1.1.2 行動商務-----------------------------------------------------------------------------------------7
1.2 研究動機------------------------------------------------------------------------------------------9
1.3 論文概述-----------------------------------------------------------------------------------------10

第二章 IOTP規格與架構

2.1 IOTP version 1簡介-------------------------------------------------------------------------11
2.2 IOTP version 1架構-------------------------------------------------------------------------11
2.3 IOTP Message與其XML格式--------------------------------------------------------14
2.4 IOTP Message處理模式------------------------------------------------------------------28
2.5 IOTP發展情形-------------------------------------------------------------------------------30
2.6 IOTP version2的需求----------------------------------------------------------------------31

第三章 公平且具不可否認性的B2C行動商務系統

3.1 簡介-----------------------------------------------------------------------------------------------33
3.2 系統架構----------------------------------------------------------------------------------------35
3.2.1 議價階段------------------------------------------------------------------------------------37
3.2.2 物流階段------------------------------------------------------------------------------------39
3.2.3 付款階段------------------------------------------------------------------------------------42
3.3 後續說明-----------------------------------------------------------------------------------------45

第四章 IOTP 與行動商務的結合與應用

4.1 動機介紹----------------------------------------------------------------------------------------46
4.2 議價階段之設計-----------------------------------------------------------------------------47
4.3 物流階段之設計-----------------------------------------------------------------------------53
4.4 付款階段之設計-----------------------------------------------------------------------------61
4.5 流程範例----------------------------------------------------------------------------------------67

第五章 分析與結論

5.1 公平性之分析-------------------------------------------------------------------------------------84
5.1.1 議價階段的公平性----------------------------------------------------------------------------84
5.1.2 物流階段的公平性----------------------------------------------------------------------------85
5.1.3 付款階段的公平性----------------------------------------------------------------------------86
5.2 不可否認性之分析------------------------------------------------------------------------------86
5.2.1 議價階段的不可否認性-----------------------------------------------------------------------86
5.2.2 物流階段的不可否認性-----------------------------------------------------------------------87
5.2.3 付款階段的不可否認性-----------------------------------------------------------------------87
5.3 IOTP相關討論------------------------------------------------------------------------------------87
5.4 結論----------------------------------------------------------------------------------------------------88
5.5 未來工作---------------------------------------------------------------------------------------------89
1.Kalakota R., and Whinston A. B., 1996, Frontiers of Electronic Commerce, Addison-Wesley.
2.賴溪松, 韓亮, 張真誠, 近代密碼學及其應用, 第2版, 松岡電腦圖書資料股份有限公司, 1998年
3.W3C XML Homepage, http://www.w3.org/XML/
4.IETF, Internet Open Trading Protocol - IOTP Version 1.0 (RFC 2801), http://www.ietf.cnri.reston.va.us/rfc/rfc2801.txt
5.IETF, Digital Signatures for the 1.0 Internet Open Trading Protocol (IOTP) (RFC 2802), http://www.ietf.cnri.reston.va.us/rfc/rfc2802.txt
6.IETF, Digest Values for DOM (DOMHASH) (RFC 2803), http://www.ietf.cnri.reston.va.us/rfc/rfc2803.txt
7.IETF, Internet Open Trading Protocol (IOTP) HTTP Supplement (RFC 2935), http://www.ietf.cnri.reston.va.us/rfc/rfc2935.txt
8.IETF, HTTP MIME Type Handler Detection (RFC 2936), http://www.ietf.cnri.reston.va.us/rfc/rfc2936.txt
9.IETF, Internet Open Trading Protocol Version 2 Requirements (RFC 3354), http://www.ietf.cnri.reston.va.us/rfc/rfc3354.txt
10.IETF, Internet Open Trading Protocol (IOTP) Version 1, Errata (RFC 3504), http://www.ietf.cnri.reston.va.us/rfc/rfc3504.txt
11.IETF, Secure Electronic Transaction (SET) Supplement for the v1.0 Internet Open Trading Protocol (IOTP) (RFC 3538), http://www.ietf.cnri.reston.va.us/rfc/rfc3538.txt
12.IETF, Payment API for v1.0 Internet Open Trading Protocol (IOTP) (RFC 3867), http://www.ietf.cnri.reston.va.us/rfc/rfc3867.txt
13.Knud Bohle, Integration of Electronic Payment Systems into B2C Internet Commerce - Problems and Perspectives, FISTE (Foresight on Information Technologies in Europe), EUR 20277 EN, April, 2002.
14.Siddharth Nautiyal, E-Commerce Support: A Report, Senior Undergraduate Department of Computer Science and Engineeting, IIT Kanpur, 1999.
15.Chun Ouyang, Jonathan Billington, On Verifying the Internet Open Trading Protocol, E-Commerce and Web Technologies: 4th International Conference, EC-Web Prague, Czech Repbulic, September 2-5, 2003, pp.292-302.
16.Chun Ouyang, Jonathan Billington, An Improved Formal Specification of the Internet Open Trading Pprotocol, Proceedings of the 2004 ACM symposium on Applied Computing, Nicosia, Cyprus, 2004, pp.779-783.
17.Chun Ouyang, Jonathan Billington, Formal Analysis of the Internet Open Trading Protocol, Applying Formal Methods: Testing, Performance, and M/E-Commerce: FORTE 2004 Workshops The FormEMC, EPEW, ITM, Toledo, Spain, October 1-2, 2004, pp1-15.
18.Chun Ouyang, Lars Michael Kristensen, Jonathan Billington, An Improved Architectural Specification of the Internet Open Trading Protocol Transactions, In Proceedings of the 3rd Workshop on Practical Use of Coloured Petri Nets and the CPN Tools (CPN'01), 2001, pp. 119-137.
19.Chun Ouyang, Lars Michael Kristensen, Jonathan Billington, A Formal and Executable Specification of the Internet Open Trading Protocol, E-Commerce and Web Technologies: Third International Conference, EC-Web 2002, Aix-en-Provence, France, September 2-6, 2002, pp.377-387.
20.Chun Ouyang, Lars Michael Kristensen, Jonathan Billington, A Formal Service Specification for the Internet Open Trading Protocol, Applications and Theory of Petri Nets 2002: 23rd International Conference, ICATPN 2002, Adelaide, Australia, June 24-30, 2002, pp.352-373.
21.S.H. Kwok, S.C. Cheung , K.C. Wong1, K.F. Tsang, S.M. Lui, K.Y. Tam, Integration of Digital Rights Management into the Internet Open Trading Protocol, Decision Support Systems archive, Volume 34, Issue 4, March, 2003, pp.413-425.
22.S. S. Grosche and H. Knospe, Secure Mobile Commerce, Electronics & Communication Engineering Journal, (2002), pp.228-238.
23.A. Tsalgatidou and E. Pitoura, Business Models and Transactions in Mobile Electronic Commerce: Requirements and Properties, Computer Networks, 37, (2001), pp.221-236.
24.J. A. Senn, The Emergence of M-Commerce, Computer, (Dec. 2000), pp.148-150.
25.U. Varshney, R. Vetter and R. Kalakota, Mobile Commerce: A New Frontier, Computer, Oct. 2000, pp.32-38.
26.A. Tsalgatidou and E. Pitoura, Business Models and Transactions in Mobile Electronic Commerce: Requirements and Properties, Computer Networks, 37, (2001), pp.221-236.
27.A. Tsalgatidou, J. Veijalainen and E. Pitoura, Challenge in Mobile ElectronicCommerce, Proceeding of IeC 2000, 3rd Int. Conf. On Innovation throughE-Commerce, UK, Nov. 14th-16th, 2000.
28.J. Veijalainen, V. Terziyan and H. Tirri, Transaction Management for M-Commerce at a Mobile Terminal, URL: http://citeseer.nj.com/574536.html
29.J. Zhou and D. Gollmann, A fair non-repudiation protocol, Proceedings of 1996 IEEE Symposium on Security and Privacy, Oakland, California, 1996, pp. 55–61.
30.J. Zhou and D. Gollmann, Observations on non-repudiation, Lecture Notes in Computer Science 1163, Advances in Cryptology: Proceedings of Asiacrypt’96, Kyongju, Korea, 1996, pp.133–144.
31.J. Zhou and D. Gollmann, Evidence and non-repudiation, Journal of Network and Computer Applications, 20, (1997), pp.267-281.
32.J. Zhou and D. Gollmann, An efficient non-repudiation protocol, Proceedings of The 10th Computer Security Foundations Workshop, IEEE Computer Society Press, Silver Spring, MD, 1997, pp.126-132.
33.J. Zhou, R. Deng and F. Bao, Evolution of fair non-repudiation with TTP, in : ACISP: Information Security and Privacy: Australasian Conference, Lecture Notes in Computer Science, vol. 1587, Springer, Berlin, 1999 pp. 258-269.
34.S. Kremer, O. Markowitch and J. Zhou, An intensive survey of fair non-repudiation protocols, Computer Communications, 25, (2002), pp.1606-1621.
35.T. Pilioura, A. Tsalgatidou and S. Hadjiefthymiades, Scenarios of using Web Services in M-Commerce, ACM SIGecom Exchanges, Vol. 3, No. 4, (Jan. 2003), pp. 28-36.
36.U. Varshney and R. Vetter, Mobile Commerce: Framework, Applications and Networking Support, Mobile Networks and Applications Vol. 7, (2002), pp.185–198.
37.N. Asokan, V. Shoup and M. Waidner, Asynchronous protocols for optimistic fair exchange, Proceedings of the IEEE Symposium on Research in Security and Privacy, 1998, pp. 86-99.
38.N. Asokan, M. Schunter and M. Waidner, Optimistic protocols for fair exchange, in Proce. 4th ACM Conference Computer Communication Security, 1997, pp.6–17.
39.N. Asokan, V. Shoup and M. Waidner, Optimistic fair exchange of digital signatures, IEEE Journal on Selected Areas in Communications, vol.18, No.4, April (2000).
QRCODE
 
 
 
 
 
                                                                                                                                                                                                                                                                                                                                                                                                               
第一頁 上一頁 下一頁 最後一頁 top
無相關期刊